summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python-xyz.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 463bfbf3bd..a526fc29b5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13149,8 +13149,9 @@ English stemmer.")
(replace 'check
(lambda _
(setenv "PYTHON" (or (which "python3") (which "python")))
- (setenv "PYCONFIG" (or (which "python3-config")
- (which "python-config")))
+ (setenv "PYCONFIG" (string-append (or (which "python3-config")
+ (which "python-config"))
+ " --embed"))
(setenv "CC" "gcc")
;; No need to extend PYTHONPATH to find the built package, since
;; the Makefile will build anyway