summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk3
-rw-r--r--gnu/packages/cpp.scm15
-rw-r--r--gnu/packages/patches/aws-sdk-cpp-cmake-prefix.patch18
-rw-r--r--gnu/packages/patches/aws-sdk-cpp-disable-networking-tests.patch44
-rw-r--r--gnu/packages/patches/aws-sdk-cpp-disable-werror.patch11
5 files changed, 85 insertions, 6 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 0a71599e68..d1803e7f59 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -884,6 +884,9 @@ dist_patch_DATA = \
%D%/packages/patches/aws-checksums-cmake-prefix.patch \
%D%/packages/patches/aws-crt-cpp-cmake-prefix.patch \
%D%/packages/patches/aws-crt-cpp-disable-networking-tests.patch \
+ %D%/packages/patches/aws-sdk-cpp-cmake-prefix.patch \
+ %D%/packages/patches/aws-sdk-cpp-disable-networking-tests.patch \
+ %D%/packages/patches/aws-sdk-cpp-disable-werror.patch \
%D%/packages/patches/azr3.patch \
%D%/packages/patches/bash-reproducible-linux-pgrp-pipe.patch \
%D%/packages/patches/bash-completion-directories.patch \
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 383c9843ca..15c3f10d72 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -923,7 +923,7 @@ aws-c-http, aws-c-io, aws-c-mqtt, aws-checksums, and s2n.")
(define-public aws-sdk-cpp
(package
(name "aws-sdk-cpp")
- (version "1.8.159")
+ (version "1.9.92")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -932,7 +932,12 @@ aws-c-http, aws-c-io, aws-c-mqtt, aws-checksums, and s2n.")
(file-name (git-file-name name version))
(sha256
(base32
- "0jpfv9x82nq7hcix9in7qgrc8009dwpg6gr96hlgmcvqrqckd2r9"))))
+ "0nbq1qivykfg8jmrn8d0k6fcfa5dw9s90wnwddh7ia4zafmby7pd"))
+ (patches
+ (search-patches
+ "aws-sdk-cpp-cmake-prefix.patch"
+ "aws-sdk-cpp-disable-networking-tests.patch"
+ "aws-sdk-cpp-disable-werror.patch"))))
(build-system cmake-build-system)
(arguments
'(;; Tests are run during the build phase.
@@ -941,11 +946,9 @@ aws-c-http, aws-c-io, aws-c-mqtt, aws-checksums, and s2n.")
'("-DBUILD_SHARED_LIBS=ON"
"-DBUILD_DEPS=OFF")))
(propagated-inputs
- `(("aws-c-common" ,aws-c-common)
- ("aws-c-event-stream" ,aws-c-event-stream)))
+ `(("aws-crt-cpp" ,aws-crt-cpp)))
(inputs
- `(("aws-checksums" ,aws-checksums)
- ("curl" ,curl)
+ `(("curl" ,curl)
("openssl" ,openssl)
("zlib" ,zlib)))
(synopsis "Amazon Web Services SDK for C++")
diff --git a/gnu/packages/patches/aws-sdk-cpp-cmake-prefix.patch b/gnu/packages/patches/aws-sdk-cpp-cmake-prefix.patch
new file mode 100644
index 0000000000..efc1218834
--- /dev/null
+++ b/gnu/packages/patches/aws-sdk-cpp-cmake-prefix.patch
@@ -0,0 +1,18 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -98,9 +98,13 @@ set(PYTHON_CMD "python")
+ # CMAKE_MODULE_PATH is a CMAKE variable. It contains a list of paths
+ # which could be used to search CMAKE modules by "include()" or "find_package()", but the default value is empty.
+ # Add ${CMAKE_INSTALL_LIBDIR}/cmake and ${CMAKE_PREFIX_PATH}/lib/cmake to search list
++if (DEFINED ENV{CMAKE_PREFIX_PATH})
++ set(CMAKE_PREFIX_PATH $ENV{CMAKE_PREFIX_PATH})
++endif()
++
+ list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_LIST_DIR}/cmake")
+-set(AWS_MODULE_DIR "/${CMAKE_INSTALL_LIBDIR}/cmake")
+-string(REPLACE ";" "${AWS_MODULE_DIR};" AWS_MODULE_PATH "${CMAKE_PREFIX_PATH}${AWS_MODULE_DIR}")
++set(AWS_MODULE_DIR "${CMAKE_INSTALL_LIBDIR}/cmake")
++string(REPLACE ":" "${AWS_MODULE_DIR};" AWS_MODULE_PATH "${CMAKE_PREFIX_PATH}${AWS_MODULE_DIR}")
+ list(APPEND CMAKE_MODULE_PATH ${AWS_MODULE_PATH})
+
+ # include() will "load and run" cmake script
diff --git a/gnu/packages/patches/aws-sdk-cpp-disable-networking-tests.patch b/gnu/packages/patches/aws-sdk-cpp-disable-networking-tests.patch
new file mode 100644
index 0000000000..3b582d9628
--- /dev/null
+++ b/gnu/packages/patches/aws-sdk-cpp-disable-networking-tests.patch
@@ -0,0 +1,44 @@
+--- a/aws-cpp-sdk-core-tests/http/HttpClientTest.cpp
++++ b/aws-cpp-sdk-core-tests/http/HttpClientTest.cpp
+@@ -92,12 +92,12 @@ TEST(HttpClientTest, TestRandomURLWithNoProxy)
+ makeRandomHttpRequest(httpClient, false);
+ }
+
+-TEST(HttpClientTest, TestRandomURLWithProxy)
+-{
+- ClientConfiguration configuration = makeClientConfigurationWithProxy();
+- auto httpClient = CreateHttpClient(configuration);
+- makeRandomHttpRequest(httpClient, true); // we expect it to try to use proxy that is invalid
+-}
++//TEST(HttpClientTest, TestRandomURLWithProxy)
++//{
++// ClientConfiguration configuration = makeClientConfigurationWithProxy();
++// auto httpClient = CreateHttpClient(configuration);
++// makeRandomHttpRequest(httpClient, true); // we expect it to try to use proxy that is invalid
++//}
+
+ TEST(HttpClientTest, TestRandomURLWithProxyAndDeclaredAsNonProxyHost)
+ {
+@@ -119,14 +119,14 @@ TEST(HttpClientTest, TestRandomURLWithProxyAndDeclaredParentDomainAsNonProxyHost
+ makeRandomHttpRequest(httpClient, false);
+ }
+
+-TEST(HttpClientTest, TestRandomURLWithProxyAndOtherDeclaredAsNonProxyHost)
+-{
+- ClientConfiguration configuration = makeClientConfigurationWithProxy();
+- configuration.nonProxyHosts = Aws::Utils::Array<Aws::String>(1);
+- configuration.nonProxyHosts[0] = "http://test.non.filtered.aws";
+- auto httpClient = CreateHttpClient(configuration);
+- makeRandomHttpRequest(httpClient, true);
+-}
++//TEST(HttpClientTest, TestRandomURLWithProxyAndOtherDeclaredAsNonProxyHost)
++//{
++// ClientConfiguration configuration = makeClientConfigurationWithProxy();
++// configuration.nonProxyHosts = Aws::Utils::Array<Aws::String>(1);
++// configuration.nonProxyHosts[0] = "http://test.non.filtered.aws";
++// auto httpClient = CreateHttpClient(configuration);
++// makeRandomHttpRequest(httpClient, true);
++//}
+
+ // TODO: Pending Fix on Windows.
+ #if ENABLE_CURL_CLIENT
diff --git a/gnu/packages/patches/aws-sdk-cpp-disable-werror.patch b/gnu/packages/patches/aws-sdk-cpp-disable-werror.patch
new file mode 100644
index 0000000000..249c299239
--- /dev/null
+++ b/gnu/packages/patches/aws-sdk-cpp-disable-werror.patch
@@ -0,0 +1,11 @@
+--- a/cmake/compiler_settings.cmake
++++ b/cmake/compiler_settings.cmake
+@@ -53,7 +53,7 @@ macro(set_gcc_flags)
+ endmacro()
+
+ macro(set_gcc_warnings)
+- list(APPEND AWS_COMPILER_WARNINGS "-Wall" "-Werror" "-pedantic" "-Wextra")
++ list(APPEND AWS_COMPILER_WARNINGS "-Wall" "-pedantic" "-Wextra")
+ if(COMPILER_CLANG)
+ if(PLATFORM_ANDROID)
+ # when using clang with libc and API lower than 21 we need to include Android support headers and ignore the gnu-include-next warning.