summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/tor.scm11
1 files changed, 7 insertions, 4 deletions
diff --git a/gnu/packages/tor.scm b/gnu/packages/tor.scm
index cb8fa7e6d0..f0e3849311 100644
--- a/gnu/packages/tor.scm
+++ b/gnu/packages/tor.scm
@@ -77,15 +77,18 @@
;; This is a style linter. It doesn't get to throw fatal errors.
(lambda _
(setenv "TOR_DISABLE_PRACTRACKER" "set")))
- (add-before 'check 'adjust-test-suite
- (lambda _
+ ,@(if (or (target-aarch64?)
+ (target-ppc32?))
;; Work around upstream issue relating to sandboxing and glibc-2.33.
;; This is similar to the issue the tor-sandbox-i686 patch fixes
;; but for other architectures.
;; https://gitlab.torproject.org/tpo/core/tor/-/issues/40381
;; https://gitlab.torproject.org/tpo/core/tor/-/merge_requests/446
- (substitute* "src/test/test_include.sh"
- ((".*Sandbox 1.*") "")))))))
+ `((add-before 'check 'adjust-test-suite
+ (lambda _
+ (substitute* "src/test/test_include.sh"
+ ((".*Sandbox 1.*") "")))))
+ '()))))
(native-inputs
`(("pkg-config" ,pkg-config)
("python" ,python))) ; for tests