summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/perl.scm12
1 files changed, 0 insertions, 12 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 47eeb48b5e..86bbeabf86 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -116,18 +116,6 @@
(lambda* (#:key configure-flags #:allow-other-keys)
(format #t "Perl configure flags: ~s~%" configure-flags)
(apply invoke "./Configure" configure-flags)))
- (add-before
- 'strip 'make-shared-objects-writable
- (lambda* (#:key outputs #:allow-other-keys)
- ;; The 'lib/perl5' directory contains ~50 MiB of .so. Make them
- ;; writable so that 'strip' actually strips them.
- (let* ((out (assoc-ref outputs "out"))
- (lib (string-append out "/lib")))
- (for-each (lambda (dso)
- (chmod dso #o755))
- (find-files lib "\\.so$"))
- #t)))
-
(add-after 'install 'remove-extra-references
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))