summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/ocaml.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index c401d4a003..c55276aa9d 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -4034,6 +4034,12 @@ part of the distribution.")
"/lib/coq/user-contrib/Coquelicot"))
#:phases
(modify-phases %standard-phases
+ (add-before 'configure 'fix-coq8.8
+ (lambda _
+ ; appcontext has been removed from coq 8.8
+ (substitute* "theories/AutoDerive.v"
+ (("appcontext") "context"))
+ #t))
(add-before 'configure 'fix-remake
(lambda _
(substitute* "remake.cpp"