summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/crates-io.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index c2a64c82ec..422a7fe61a 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -37788,6 +37788,30 @@ contents.")
(base32
"02942l2gc7w5r4js7i9063x99szic5mzzk1055j83v4diqpbpxck"))))))
+(define-public rust-open-2
+ (package
+ (name "rust-open")
+ (version "2.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "open" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1dq9c6dgq7iv5kvqfk8gvkfq34j5pdinfcs1hbdd4x6i62vf8vhp"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-pathdiff" ,rust-pathdiff-0.2)
+ ("rust-winapi" ,rust-winapi-0.3))))
+ (home-page "https://github.com/Byron/open-rs")
+ (synopsis "Open a path or URL using the program configured on the system")
+ (description
+ "Use this library to open a path or URL using the program configured on
+the system.")
+ (license license:expat)))
+
(define-public rust-open-1
(package
(name "rust-open")