summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/xorg.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 79139d01c1..def751c62c 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -2920,7 +2920,13 @@ framebuffer device.")
`(#:configure-flags
(list (string-append "--with-xorg-conf-dir="
(assoc-ref %outputs "out")
- "/share/X11/xorg.conf.d"))))
+ "/share/X11/xorg.conf.d"))
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'bootstrap
+ (lambda _
+ ;; autogen.sh calls configure unconditionally.
+ (invoke "autoreconf" "-vfi"))))))
(home-page "https://www.x.org/wiki/")
(synopsis "Adreno video driver for X server")
(description