summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/linux.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index c3a6a43550..40cb49c5ce 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -7693,6 +7693,8 @@ compatible with Python's ConfigParser style of .INI files, including RFC
(outputs (list "out" "python"))
(arguments
`(#:tests? #f ; kernel/user integration tests are in package "xfstests"
+ #:configure-flags
+ (list "--disable-static")
#:make-flags
(list "V=1")
#:phases
@@ -7732,6 +7734,9 @@ file systems.")
(outputs (list "out"))
(arguments
(substitute-keyword-arguments (package-arguments xfsprogs)
+ ((#:configure-flags configure-flags '())
+ `(append ,configure-flags
+ (list "--enable-static")))
((#:make-flags make-flags ''())
`(cons* "LLDFLAGS=-all-static" ,make-flags))
((#:phases _ ''())