summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/pantheon.scm27
1 files changed, 10 insertions, 17 deletions
diff --git a/gnu/packages/pantheon.scm b/gnu/packages/pantheon.scm
index 87d292d2c7..756db94144 100644
--- a/gnu/packages/pantheon.scm
+++ b/gnu/packages/pantheon.scm
@@ -26,6 +26,7 @@
#:use-module (gnu packages gtk)
#:use-module (gnu packages package-management)
#:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages python)
#:use-module (gnu packages xml)
#:use-module (gnu packages)
#:use-module (guix build-system meson)
@@ -37,7 +38,7 @@
(define-public granite
(package
(name "granite")
- (version "5.5.0")
+ (version "6.2.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -46,24 +47,16 @@
(file-name (git-file-name name version))
(sha256
(base32
- "13qfhq8xndikk6kmybibs6a4ddyp6mhvbsp2yy4qr7aiiyxf7mna"))))
+ "0ilslmg63hh2x7h5rvs3mhzw1y9ixhhkqnn1j1lzwm12v2iidkaq"))))
(build-system meson-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'disable-icon-cache
- (lambda _
- (setenv "DESTDIR" "/")
- #t)))))
- (inputs
- `(("glib" ,glib)
- ("gtk" ,gtk+)
- ("libgee" ,libgee)))
- (native-inputs
- `(("gettext" ,gettext-minimal)
- ("gobject-introspection" ,gobject-introspection)
- ("pkg-config" ,pkg-config)
- ("vala" ,vala)))
+ `(#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'disable-icon-cache
+ (lambda _
+ (setenv "DESTDIR" "/"))))))
+ (inputs (list glib gtk+ libgee))
+ (native-inputs (list gettext-minimal gobject-introspection pkg-config
+ python vala))
(home-page "https://github.com/elementary/granite")
(synopsis "Library that extends GTK with common widgets and utilities")
(description "Granite is a companion library for GTK+ and GLib. Among other