summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/antivirus.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/antivirus.scm b/gnu/packages/antivirus.scm
index 95749761bd..c3f11865e2 100644
--- a/gnu/packages/antivirus.scm
+++ b/gnu/packages/antivirus.scm
@@ -112,8 +112,10 @@
;; install sample .conf files to %output/etc rather than /etc/clamav
#:make-flags (list (string-append "sysconfdir=" %output "/etc"))
#:phases (modify-phases %standard-phases
+ ;; Regenerate configure script. Without this we don't get
+ ;; the correct value for LLVM linker variables.
(add-after 'unpack 'reconf
- (lambda _ (zero? (system* "autoreconf" "-vfi"))))
+ (lambda _ (invoke "autoreconf" "-vfi")))
(add-before 'configure 'patch-llvm-config
(lambda _
(substitute* '("libclamav/c++/detect.cpp"