summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/bittorrent.scm32
-rw-r--r--gnu/packages/patches/transmission-remote-gtk-fix-appstream.patch61
3 files changed, 94 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 3f132672c8..62a5e41a46 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1762,6 +1762,7 @@ dist_patch_DATA = \
%D%/packages/patches/tlf-support-hamlib-4.2+.patch \
%D%/packages/patches/transcode-ffmpeg.patch \
%D%/packages/patches/transmission-honor-localedir.patch \
+ %D%/packages/patches/transmission-remote-gtk-fix-appstream.patch \
%D%/packages/patches/ttf2eot-cstddef.patch \
%D%/packages/patches/tup-unbundle-dependencies.patch \
%D%/packages/patches/tuxpaint-stamps-path.patch \
diff --git a/gnu/packages/bittorrent.scm b/gnu/packages/bittorrent.scm
index 0ca60d607c..e17e04dcfe 100644
--- a/gnu/packages/bittorrent.scm
+++ b/gnu/packages/bittorrent.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2019, 2020 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
+;;; Copyright © 2021 Justin Veilleux <terramorpha@cock.li>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -38,6 +39,7 @@
#:use-module (guix utils)
#:use-module (gnu packages)
#:use-module (gnu packages adns)
+ #:use-module (gnu packages autotools)
#:use-module (gnu packages boost)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
@@ -45,6 +47,7 @@
#:use-module (gnu packages curl)
#:use-module (gnu packages cyrus-sasl)
#:use-module (gnu packages freedesktop)
+ #:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
#:use-module (gnu packages gnupg)
@@ -138,6 +141,35 @@ DHT, µTP, PEX and Magnet Links.")
;; A few files files carry an MIT/X11 license header.
(license (list l:gpl2 l:gpl3))))
+(define-public transmission-remote-gtk
+ (package
+ (name "transmission-remote-gtk")
+ (version "1.4.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/transmission-remote-gtk/"
+ "transmission-remote-gtk/releases/download/"
+ version "/transmission-remote-gtk-" version
+ ".tar.xz"))
+ (patches (search-patches "transmission-remote-gtk-fix-appstream.patch"))
+ (sha256
+ (base32 "1aqjl5rgamgcgqvcldd1gzyfh2xci0m7070924d6vz2qln0q75sr"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("gettext" ,gnu-gettext)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("appstream-glib" ,appstream-glib)
+ ("curl" ,curl)
+ ("gtk+" ,gtk+)
+ ("json-glib" ,json-glib)))
+ (synopsis "Gtk frontend to the Transmission daemon")
+ (description "transmission-remote-gtk is a GTK client for remote management
+of the Transmission BitTorrent client, using its HTTP RPC protocol.")
+ (home-page "https://github.com/transmission-remote-gtk/transmission-remote-gtk")
+ (license l:gpl2+)))
+
(define-public libtorrent
(package
(name "libtorrent")
diff --git a/gnu/packages/patches/transmission-remote-gtk-fix-appstream.patch b/gnu/packages/patches/transmission-remote-gtk-fix-appstream.patch
new file mode 100644
index 0000000000..e7d4c8bb86
--- /dev/null
+++ b/gnu/packages/patches/transmission-remote-gtk-fix-appstream.patch
@@ -0,0 +1,61 @@
+Fix a bug related to AppStream:
+
+https://github.com/transmission-remote-gtk/transmission-remote-gtk/issues/95
+
+Patch adapted from upstream source repository:
+
+https://github.com/transmission-remote-gtk/transmission-remote-gtk/commit/89259ff90c703c7fe6768b5317803b9aa5b5ab8c
+
+From 89259ff90c703c7fe6768b5317803b9aa5b5ab8c Mon Sep 17 00:00:00 2001
+From: Alan <alan-github@eth0.org.uk>
+Date: Tue, 17 Nov 2020 01:26:22 +0000
+Subject: [PATCH] fix screenshot and add OARS rating so appdata validates
+
+---
+ README.md | 5 ++---
+ data/io.github.TransmissionRemoteGtk.appdata.xml.in | 5 +++--
+ 2 files changed, 5 insertions(+), 5 deletions(-)
+
+diff --git a/README.md b/README.md
+index 4306cc7..d38314b 100644
+--- a/README.md
++++ b/README.md
+@@ -6,13 +6,12 @@ the Transmission BitTorrent client, using its HTTP RPC protocol.
+
+ # DEPENDENCIES
+
+-The following packages are required dependencies:
++The following packages are required dependencies (debian/ubuntu).
+
+ ```bash
+-autoconf-archive appstream-glib intltool
++libgtk-3-dev automake autoconf gcc libgeoip-dev gettext autoconf-archive libappstream-dev appstream-util libcurl4-openssl-dev libjson-glib-dev
+ ```
+
+-
+ # BUILDING
+
+ Optionally install `libgeoip` and its headers to see the country
+diff --git a/data/io.github.TransmissionRemoteGtk.appdata.xml.in b/data/io.github.TransmissionRemoteGtk.appdata.xml.in
+index fc35a8f..1476c2a 100644
+--- a/data/io.github.TransmissionRemoteGtk.appdata.xml.in
++++ b/data/io.github.TransmissionRemoteGtk.appdata.xml.in
+@@ -7,6 +7,7 @@
+ <translation type="gettext">transmission-remote-gtk</translation>
+ <name>Transmission Remote</name>
+ <developer_name>Transmission Remote Gtk Team</developer_name>
++ <content_rating type="oars-1.1" />
+ <summary>Remotely manage the Transmission BitTorrent client</summary>
+ <url type="homepage">https://github.com/transmission-remote-gtk/transmission-remote-gtk</url>
+ <url type="bugtracker">https://github.com/transmission-remote-gtk/transmission-remote-gtk/issues</url>
+@@ -23,8 +24,8 @@
+ </ul>
+ </description>
+ <screenshots>
+- <screenshot height="576" width="1024" type="default">
+- <image>http://eth0.org.uk/~alan/transmission-remote-gtk-1.1.1.png</image>
++ <screenshot height="512" width="973" type="default">
++ <image>https://community.linuxmint.com/img/screenshots/transmission-remote-gtk.png</image>
+ </screenshot>
+ </screenshots>
+ <releases>