summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--doc/guix.texi9
-rw-r--r--gnu/packages/python.scm1
2 files changed, 7 insertions, 3 deletions
diff --git a/doc/guix.texi b/doc/guix.texi
index a3eba5811e..2691e24faf 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -13579,7 +13579,6 @@ for instance, the module python-dateutil is packaged under the names
starts with @code{py} (e.g. @code{pytz}), we keep it and prefix it as
described above.
-
@subsubsection Specifying Dependencies
@cindex inputs, for Python packages
@@ -13596,6 +13595,11 @@ following check list to determine which dependency goes where.
@itemize
@item
+We currently package Python 2 with @code{setuptools} and @code{pip}
+installed like Python 3.4 has per default. Thus you don't need to
+specify either of these as an input.
+
+@item
Python dependencies required at run time go into
@code{propagated-inputs}. They are typically defined with the
@code{install_requires} keyword in @file{setup.py}, or in the
@@ -13609,8 +13613,7 @@ testing---e.g., those in @code{tests_require}---go into
propagated because they are not needed at run time, and (2) in a
cross-compilation context, it's the ``native'' input that we'd want.
-Examples are @code{setuptools}, which is usually needed only at build
-time, or the @code{pytest}, @code{mock}, and @code{nose} test
+Examples are the @code{pytest}, @code{mock}, and @code{nose} test
frameworks. Of course if any of these packages is also required at
run-time, it needs to go to @code{propagated-inputs}.
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 18e485ab2e..b6aeb8c032 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -162,6 +162,7 @@
#:configure-flags
(list "--enable-shared" ;allow embedding
"--with-system-ffi" ;build ctypes
+ "--with-ensurepip=install" ;install pip and setuptools
(string-append "LDFLAGS=-Wl,-rpath="
(assoc-ref %outputs "out") "/lib"))