summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/libreoffice.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index e285e5f897..fc0ca836fa 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -163,10 +163,12 @@ into other word processors.")
`(("cppunit" ,cppunit)
("gperf" ,gperf)
("pkg-config" ,pkg-config)))
- (inputs `(("boost" ,boost)
- ("icu4c" ,icu4c)
- ("librevenge" ,librevenge)
- ("libxml2" ,libxml2)))
+ (propagated-inputs ; in Requires or Requires.private field of .pkg
+ `(("icu4c" ,icu4c)
+ ("librevenge" ,librevenge)
+ ("libxml2" ,libxml2)))
+ (inputs
+ `(("boost" ,boost)))
(arguments
;; avoid triggering configure errors by simple inclusion of boost headers
`(#:configure-flags '("--disable-werror")))