summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/crates-io.scm34
1 files changed, 26 insertions, 8 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 7750c4ab82..036a971a98 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -24282,8 +24282,33 @@ Derivation Function (HKDF).")
(("rust-digest" ,rust-digest-0.8)
("rust-hmac" ,rust-hmac-0.7))))))
+(define-public rust-hmac-0.12
+ (package
+ (name "rust-hmac")
+ (version "0.12.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "hmac" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "18nnjkvvpkjw6ppcyijysgxmr4a7knd98msb6vgy4b3z7qgi7jnx"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs (("rust-digest" ,rust-digest-0.10))))
+ (home-page "https://github.com/RustCrypto/MACs")
+ (synopsis "Generic implementation of Hash-based Message Authentication Code")
+ (description
+ "This package provides a generic implementation of @acronym{HMAC,
+Hash-based Message Authentication Code}.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-hmac-0.11
(package
+ (inherit rust-hmac-0.12)
(name "rust-hmac")
(version "0.11.0")
(source
@@ -24295,7 +24320,6 @@ Derivation Function (HKDF).")
(sha256
(base32
"16z61aibdg4di40sqi4ks2s4rz6r29w4sx4gvblfph3yxch26aia"))))
- (build-system cargo-build-system)
(arguments
`(#:cargo-inputs
(("rust-crypto-mac" ,rust-crypto-mac-0.11)
@@ -24304,13 +24328,7 @@ Derivation Function (HKDF).")
(("rust-crypto-mac" ,rust-crypto-mac-0.11)
("rust-md-5" ,rust-md-5-0.9)
("rust-sha2" ,rust-sha2-0.9)
- ("rust-streebog" ,rust-streebog-0.9))))
- (home-page "https://github.com/RustCrypto/MACs")
- (synopsis "Generic implementation of Hash-based Message Authentication Code")
- (description
- "This package provides a generic implementation of @acronym{HMAC,
-Hash-based Message Authentication Code}.")
- (license (list license:expat license:asl2.0))))
+ ("rust-streebog" ,rust-streebog-0.9))))))
(define-public rust-hmac-0.10
(package