summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python-xyz.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b94045d210..52ee3b2f81 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -26082,8 +26082,8 @@ and plain text.")
'(#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda _
- (invoke "python" "setup.py" "nosetests"))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests? (invoke "nosetests")))))))
(native-inputs
(list python-nose))
(propagated-inputs