summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/golang.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 12561c0a32..dc431b173a 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5129,6 +5129,34 @@ the parse trees produced by the html package.")
to jQuery to the Go language.")
(license license:bsd-3)))
+(define-public go-github-com-jmespath-go-jmespath
+ (package
+ (name "go-github-com-jmespath-go-jmespath")
+ (version "0.4.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jmespath/go-jmespath")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "18zyr9nlywmwp3wpzcjxrgq9s9d2mmc6zg6xhsna00m663nkyc3n"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/jmespath/go-jmespath"))
+ (native-inputs
+ `(("go-github-com-davecgh-go-spew" ,go-github-com-davecgh-go-spew)
+ ("go-github-com-pmezard-go-difflib" ,go-github-com-pmezard-go-difflib)
+ ("go-gopkg-in-yaml-v2" ,go-gopkg-in-yaml-v2)))
+ (home-page "https://github.com/jmespath/go-jmespath")
+ (synopsis "Golang implementation of JMESPath")
+ (description
+ "This package implements JMESPath, a query language for JSON. It
+transforms one JSON document into another through a JMESPath expression.")
+ (license license:asl2.0)))
+
(define-public go-github-com-aymerick-douceur
(package
(name "go-github-com-aymerick-douceur")