summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/gnuzilla.scm4
-rw-r--r--gnu/packages/node.scm22
2 files changed, 4 insertions, 22 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index afe5768faf..13bba7b661 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -791,7 +791,7 @@ from forcing GEXP-PROMISE."
("llvm" ,llvm)
("clang" ,clang)
("perl" ,perl)
- ("node" ,node-10.22)
+ ("node" ,node)
("python" ,python)
("python-2" ,python-2)
("python2-pysqlite" ,python2-pysqlite)
@@ -1460,7 +1460,7 @@ standards of the IceCat project.")
("clang" ,clang)
("llvm" ,llvm)
("nasm" ,nasm)
- ("node" ,node-10.22)
+ ("node" ,node)
("perl" ,perl)
("pkg-config" ,pkg-config)
("python" ,python)
diff --git a/gnu/packages/node.scm b/gnu/packages/node.scm
index f04e39bbd5..66ef4f0905 100644
--- a/gnu/packages/node.scm
+++ b/gnu/packages/node.scm
@@ -48,14 +48,14 @@
(define-public node
(package
(name "node")
- (version "10.20.0")
+ (version "10.22.1")
(source (origin
(method url-fetch)
(uri (string-append "https://nodejs.org/dist/v" version
"/node-v" version ".tar.xz"))
(sha256
(base32
- "0cvjwnl0wkcsyw3kannbdv01s235wrnp11n2s6swzjx95gpichfi"))
+ "0pr569qiabr4m7k38s7rwi3iyzrc5jmx19z2z0k7n4xfvhjlfzzl"))
(modules '((guix build utils)))
(snippet
`(begin
@@ -201,24 +201,6 @@ devices.")
(properties '((max-silent-time . 7200) ;2h, needed on ARM
(timeout . 21600))))) ;6h
-;; TODO: Make this the default node on core-updates. This cannot be done on
-;; master since this version of node requires a newer nghttp2 library at link
-;; time.
-(define-public node-10.22
- (package
- (inherit node)
- (version "10.22.1")
- (source (origin
- (inherit (package-source node))
- (uri (string-append "https://nodejs.org/dist/v" version
- "/node-v" version ".tar.xz"))
- (sha256
- (base32
- "0pr569qiabr4m7k38s7rwi3iyzrc5jmx19z2z0k7n4xfvhjlfzzl"))))
- (inputs
- (alist-replace "nghttp2" (list nghttp2-1.41 "lib")
- (package-inputs node)))))
-
(define-public libnode
(package
(inherit node)