summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/tls.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/tls.scm b/gnu/packages/tls.scm
index 0bce6e1bc7..e7baa52ec5 100644
--- a/gnu/packages/tls.scm
+++ b/gnu/packages/tls.scm
@@ -237,6 +237,16 @@ required structures.")
(string-prefix? "armhf" (%current-system)))
'("-mfpu=vfpv3")
'()))))))
+ (add-after
+ 'install 'make-libraries-writable
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Make libraries writable so that 'strip' does its job.
+ (let ((out (assoc-ref outputs "out")))
+ (for-each (lambda (file)
+ (chmod file #o644))
+ (find-files (string-append out "/lib")
+ "\\.so"))
+ #t)))
(add-before
'patch-source-shebangs 'patch-tests
(lambda* (#:key inputs native-inputs #:allow-other-keys)