summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/xdisorg.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/xdisorg.scm b/gnu/packages/xdisorg.scm
index 9646f55b99..68f856f81f 100644
--- a/gnu/packages/xdisorg.scm
+++ b/gnu/packages/xdisorg.scm
@@ -2869,8 +2869,13 @@ and execute @file{.desktop} files of the Application type.")
(list (string-append "PREFIX=" out)))
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'refer-to-xauth
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "sx"
+ (("\\bxauth\\b" command)
+ (string-append (assoc-ref inputs "xauth") "/bin/" command)))))
(delete 'configure)))) ; no configure script
- (propagated-inputs
+ (inputs
`(("xauth" ,xauth)))
(home-page "https://github.com/Earnestly/sx")
(synopsis "Start an xorg server")