summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/crypto.scm25
1 files changed, 13 insertions, 12 deletions
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index 4826b3851c..85729471f5 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -383,18 +383,19 @@ the wrong hands.")
"$(LNS) "))))))
(build-system gnu-build-system)
(arguments
- `(#:phases (modify-phases %standard-phases
- (delete 'configure)) ; no configure script
- #:make-flags (list ,(string-append "CC=" (cc-for-target))
- "RPATH=-Wl,-rpath,$(DESTDIR)$(LIBDIR)"
- (string-append "DESTDIR="
- (assoc-ref %outputs "out"))
- "INCLUDEDIR=/include"
- "LIBDIR=/lib"
- "MANDIR=/share/man"
- "SHAREDIR=/share/keyutils"
- "NO_ARLIB=1") ; omit static libraries
- #:test-target "test"))
+ (list #:make-flags
+ #~(list (string-append "CC=" #$(cc-for-target))
+ "RPATH=-Wl,-rpath,$(DESTDIR)$(LIBDIR)"
+ (string-append "DESTDIR=" #$output)
+ "INCLUDEDIR=/include"
+ "LIBDIR=/lib"
+ "MANDIR=/share/man"
+ "SHAREDIR=/share/keyutils"
+ "NO_ARLIB=1") ; omit static libraries
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)) ; no configure script
+ #:test-target "test"))
(inputs
(list mit-krb5))
(home-page "https://people.redhat.com/dhowells/keyutils/")