summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/man.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/man.scm b/gnu/packages/man.scm
index d9e8b07471..c6d8b8881d 100644
--- a/gnu/packages/man.scm
+++ b/gnu/packages/man.scm
@@ -183,10 +183,17 @@ a flexible and convenient way.")
(string-append "--with-xz=" xz "/bin/xz")
(string-append "--with-col=" util "/bin/col")
;; The default systemd directories ignore --prefix.
+ ;; XXX TODO: Replace with simply #$OUTPUT on staging.
(string-append "--with-systemdsystemunitdir="
- %output "/lib/systemd/system")
+ #$(if (%current-target-system)
+ #~#$output
+ #~%output)
+ "/lib/systemd/system")
(string-append "--with-systemdtmpfilesdir="
- %output "/lib/tmpfiles.d"))
+ #$(if (%current-target-system)
+ #~#$output
+ #~%output)
+ "/lib/tmpfiles.d"))
(map (lambda (prog)
(string-append "--with-" prog "=" groff-minimal
"/bin/" prog))