summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/machine-learning.scm2
-rw-r--r--gnu/packages/patches/python-onnx-use-system-googletest.patch3
2 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 9ac1a79844..108bcbdfef 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -589,8 +589,6 @@ in terms of new algorithms.")
(origin
(method url-fetch)
(uri (pypi-uri "onnx" version))
- ;; ONNX will build googletest from a git checkout. Patch CMake
- ;; to use googletest from Guix and enable tests by default.
(patches (search-patches "python-onnx-use-system-googletest.patch"))
(sha256
(base32 "0yjv2axz2vc2ysniwislsp53fsb8f61y1warrr2ppn2d9ijml1d9"))))
diff --git a/gnu/packages/patches/python-onnx-use-system-googletest.patch b/gnu/packages/patches/python-onnx-use-system-googletest.patch
index 33d2fa12de..5dfcbc6dc3 100644
--- a/gnu/packages/patches/python-onnx-use-system-googletest.patch
+++ b/gnu/packages/patches/python-onnx-use-system-googletest.patch
@@ -1,3 +1,6 @@
+ONNX will build googletest from a Git checkout. Patch CMake to use our
+googletest package and enable tests by default.
+
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0aa9fda2..a573170c 100644
--- a/CMakeLists.txt