summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/games.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 4c297005dc..60d885500c 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2784,6 +2784,12 @@ fullscreen, use F5 or Alt+Enter.")
(lambda _
(substitute* "icons/Makefile.in"
(("\\$\\(INSTALL_DATA\\) \\$\\(srcdir\\)/warzone2100.appdata.xml.*") ""))
+ #t))
+ (add-after 'unpack 'patch-for-qt5.8
+ (lambda _
+ (substitute* "lib/widget/editbox.cpp"
+ (("== '\\\\0'")
+ "== QChar('\\0')"))
#t)))))
(native-inputs `(("pkg-config" ,pkg-config)
("unzip" ,unzip)
@@ -2797,7 +2803,8 @@ fullscreen, use F5 or Alt+Enter.")
("libxrandr" ,libxrandr)
("openal" ,openal)
("physfs" ,physfs)
- ("qt" ,qt)
+ ("qtbase" ,qtbase)
+ ("qtscript" ,qtscript)
("openssl" ,openssl)
("quesoglc" ,quesoglc)
("sdl2" ,sdl2)))