summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/cpp.scm5
-rw-r--r--gnu/packages/patches/abseil-cpp-fix-gtest.patch16
3 files changed, 1 insertions, 21 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 618a13d840..4f910300ef 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -823,7 +823,6 @@ dist_patch_DATA = \
%D%/packages/patches/abcl-fix-build-xml.patch \
%D%/packages/patches/ableton-link-system-libraries-debian.patch \
%D%/packages/patches/abiword-explictly-cast-bools.patch \
- %D%/packages/patches/abseil-cpp-fix-gtest.patch \
%D%/packages/patches/abseil-cpp-fix-strerror_test.patch \
%D%/packages/patches/adb-add-libraries.patch \
%D%/packages/patches/adb-libssl_11-compatibility.patch \
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index fe49d1f1b3..77ed9e0c97 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -778,11 +778,8 @@ point and then, after each tween step, plugging back the result.")
(sha256
(base32
"1p4djhm1f011ficbjjxx3n8428p8481p20j4glpaawnpsi362hkl"))
- ;; Remove after next googletest release and update.
(patches
- (search-patches
- "abseil-cpp-fix-gtest.patch"
- "abseil-cpp-fix-strerror_test.patch"))))
+ (search-patches "abseil-cpp-fix-strerror_test.patch"))))
(build-system cmake-build-system)
(arguments
`(#:configure-flags (list "-DBUILD_SHARED_LIBS=ON"
diff --git a/gnu/packages/patches/abseil-cpp-fix-gtest.patch b/gnu/packages/patches/abseil-cpp-fix-gtest.patch
deleted file mode 100644
index 38971448f3..0000000000
--- a/gnu/packages/patches/abseil-cpp-fix-gtest.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-The GTEST_ALLOW_UNINSTANTIATED_PARAMTERIZED_TEST macro was added to googletest
-in commit 0b024bd9 on master. It has been used in an abseil-cpp release before
-a googletest release.
-
---- a/absl/container/internal/unordered_map_modifiers_test.h
-+++ b/absl/container/internal/unordered_map_modifiers_test.h
-@@ -286,7 +286,9 @@ class UniquePtrModifiersTest : public ::testing::Test {
- }
- };
-
-+#ifdef GTEST_ALLOW_UNINSTANTIATED_PARAMETERIZED_TEST
- GTEST_ALLOW_UNINSTANTIATED_PARAMETERIZED_TEST(UniquePtrModifiersTest);
-+#endif
-
- TYPED_TEST_SUITE_P(UniquePtrModifiersTest);
-