summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/golang-crypto.scm26
-rw-r--r--gnu/packages/golang.scm27
2 files changed, 26 insertions, 27 deletions
diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index c57c525a49..9fec753a35 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -223,6 +223,32 @@ Cryptography (ECC).")
messages.")
(license license:expat)))
+(define-public go-github-com-flynn-noise
+ (package
+ (name "go-github-com-flynn-noise")
+ (version "1.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/flynn/noise")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1j6phxyqx06wcqxjpin696fkp85s76qcp3i2f7fv6q2fb6618f6y"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/flynn/noise"))
+ (propagated-inputs
+ (list go-gopkg-in-check-v1 go-golang-org-x-crypto))
+ (home-page "https://github.com/flynn/noise")
+ (synopsis "Go implementation of the Noise protocol framework")
+ (description "@code{noise} implements the Noise protocol framework. Noise
+is a low-level framework for building crypto protocols. Noise protocols
+support mutual and optional authentication, identity hiding, forward secrecy,
+zero round-trip encryption, and other advanced features.")
+ (license license:bsd-3)))
+
(define-public go-github-com-gaukas-godicttls
(package
(name "go-github-com-gaukas-godicttls")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index e6a0578b64..60bb95397b 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -10412,33 +10412,6 @@ back.")
terminals, as commonly found on Unix systems.")
(license license:bsd-3)))
-(define-public go-github-com-flynn-noise
- (package
- (name "go-github-com-flynn-noise")
- (version "1.0.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/flynn/noise")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1j6phxyqx06wcqxjpin696fkp85s76qcp3i2f7fv6q2fb6618f6y"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/flynn/noise"))
- (propagated-inputs
- (list go-gopkg-in-check-v1 go-golang-org-x-crypto))
- (home-page "https://github.com/flynn/noise")
- (synopsis "Go implementation of the Noise protocol framework")
- (description "@code{noise} implements the Noise protocol framework. Noise
-is a low-level framework for building crypto protocols. Noise protocols
-support mutual and optional authentication, identity hiding, forward secrecy,
-zero round-trip encryption, and other advanced features.")
- (license license:bsd-3)))
-
(define-public go-github-com-klauspost-compress
(package
(name "go-github-com-klauspost-compress")