summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python-xyz.scm29
1 files changed, 1 insertions, 28 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 20de20a229..9daacb9777 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -24317,34 +24317,7 @@ Features:
(license license:asl2.0)))
(define-public python-pre-commit
- (package
- (name "python-pre-commit")
- (version "2.10.0")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "pre_commit" version))
- (sha256
- (base32 "1ycf6wpxrhxhdzz0vpryhbdxlwik5khgcvp3hxwvfr447a6k84zl"))))
- (build-system python-build-system)
- (arguments
- ;; Tests fail with "AttributeError: module 'pre_commit.resources' has no
- ;; attribute 'empty_template_setup'".
- `(#:tests? #false))
- (propagated-inputs
- (list python-cfgv
- python-identify
- python-importlib-metadata
- python-nodeenv
- python-pyyaml
- python-toml
- python-virtualenv))
- (home-page "https://github.com/pre-commit/pre-commit")
- (synopsis "Framework for managing multi-language pre-commit hooks")
- (description
- "This package provides a framework for managing and maintaining
-multi-language pre-commit hooks.")
- (license license:expat)))
+ (deprecated-package "python-pre-commit" pre-commit))
(define-public python-precis-i18n
(package