summaryrefslogtreecommitdiff
path: root/tests
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-12-16 13:32:11 +0100
committerMathieu Othacehe <othacehe@gnu.org>2021-12-23 10:54:00 +0100
commit05a9d1f378e2e13e8f759be926ea368358afc27c (patch)
tree65d56f5e77e779ccddebc23e423021e3d9281c68 /tests
parentda924796744bbb7b035a986fe5d28d8d613ff6af (diff)
downloadguix-patches-05a9d1f378e2e13e8f759be926ea368358afc27c.tar
guix-patches-05a9d1f378e2e13e8f759be926ea368358afc27c.tar.gz
Remove VM generation dead-code.
This code duplicates the (gnu system image) and (gnu build image) code. Using VM for image generation is not needed, not portable and really slow. Remove all the VM image generation code to make sure that only the image API is used. * gnu/build/vm.scm: Remove it. Move the qemu-command procedure to ... * gnu/build/marionette.scm: ... here. * gnu/local.mk (GNU_SYSTEM_MODULES): Adapt it. * tests/modules.scm: Ditto. * gnu/tests/install.scm: Ditto. * gnu/system/vm.scm: Adapt it and remove expression->derivation-in-linux-vm, qemu-img, system-qemu-image/shared-store and system-docker-image procedures. * doc/guix.texi (G-Expressions): Adapt it.
Diffstat (limited to 'tests')
-rw-r--r--tests/modules.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/tests/modules.scm b/tests/modules.scm
index 57019c600c..e70d2d9e08 100644
--- a/tests/modules.scm
+++ b/tests/modules.scm
@@ -39,10 +39,10 @@
(live-module-closure '((gnu build install)))
(source-module-closure '((gnu build install)))))
-(test-assert "closure of (gnu build vm)"
+(test-assert "closure of (gnu build image)"
(lset= equal?
- (live-module-closure '((gnu build vm)))
- (source-module-closure '((gnu build vm)))))
+ (live-module-closure '((gnu build image)))
+ (source-module-closure '((gnu build image)))))
(test-equal "&missing-dependency-error"
'(something that does not exist)