summaryrefslogtreecommitdiff
path: root/tests/derivations.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-01-30 16:30:49 +0100
committerLudovic Courtès <ludo@gnu.org>2013-01-30 16:30:49 +0100
commita9ebd9efd0d97159acbec848ad5fe06f022c8235 (patch)
tree718f8a04ac525537ed2e297bf38bbedb68f4e8f1 /tests/derivations.scm
parentfd060fd30da53f2b0856f6f451f8fd7b8c760d70 (diff)
downloadguix-patches-a9ebd9efd0d97159acbec848ad5fe06f022c8235.tar
guix-patches-a9ebd9efd0d97159acbec848ad5fe06f022c8235.tar.gz
store: Remove the `fixed?' parameter from `add-to-store'.
* guix/store.scm (add-to-store): Remove the `fixed?' parameter from the public interface. * gnu/packages/bootstrap.scm, guix-download.in, guix/derivations.scm, guix/packages.scm, tests/derivations.scm: Update all callers accordingly.
Diffstat (limited to 'tests/derivations.scm')
-rw-r--r--tests/derivations.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/tests/derivations.scm b/tests/derivations.scm
index 83c8d444d7..314942a352 100644
--- a/tests/derivations.scm
+++ b/tests/derivations.scm
@@ -51,7 +51,7 @@
(define %bash
(let ((bash (search-bootstrap-binary "bash" (%current-system))))
(and %store
- (add-to-store %store "bash" #t #t "sha256" bash))))
+ (add-to-store %store "bash" #t "sha256" bash))))
(define (directory-contents dir)
"Return an alist representing the contents of DIR."
@@ -86,7 +86,7 @@
(test-assert "add-to-store, flat"
(let* ((file (search-path %load-path "language/tree-il/spec.scm"))
- (drv (add-to-store %store "flat-test" #t #f "sha256" file)))
+ (drv (add-to-store %store "flat-test" #f "sha256" file)))
(and (eq? 'regular (stat:type (stat drv)))
(valid-path? %store drv)
(equal? (call-with-input-file file get-bytevector-all)
@@ -94,7 +94,7 @@
(test-assert "add-to-store, recursive"
(let* ((dir (dirname (search-path %load-path "language/tree-il/spec.scm")))
- (drv (add-to-store %store "dir-tree-test" #t #t "sha256" dir)))
+ (drv (add-to-store %store "dir-tree-test" #t "sha256" dir)))
(and (eq? 'directory (stat:type (stat drv)))
(valid-path? %store drv)
(equal? (directory-contents dir)
@@ -145,7 +145,7 @@
;; name to the builder.
. ,(add-to-store %store
(basename input)
- #t #t "sha256"
+ #t "sha256"
input)))
`((,builder)
(,input))))) ; ← local file name