summaryrefslogtreecommitdiff
path: root/tests/build-utils.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-11-17 18:00:28 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-11-17 18:00:28 -0500
commit129b9b16d9b588316cc997cf8f4fefe30961a417 (patch)
treebc1dc50e83af6e9afb2ee24cd32f5e42e039642e /tests/build-utils.scm
parent5f9c92dd6285a1ef326cf5aa99781f1f3acbd245 (diff)
parent9113de2ca2db195908e3262b3752f8392ada8630 (diff)
downloadguix-patches-129b9b16d9b588316cc997cf8f4fefe30961a417.tar
guix-patches-129b9b16d9b588316cc997cf8f4fefe30961a417.tar.gz
Merge remote-tracking branch 'origin/version-1.2.0' into master
Conflicts: gnu/packages/bioinformatics.scm The python-pysam package fixed in master was kept instead of the update done in the version-1.2.0 branch.
Diffstat (limited to 'tests/build-utils.scm')
-rw-r--r--tests/build-utils.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/tests/build-utils.scm b/tests/build-utils.scm
index 47a57a984b..654b480ed9 100644
--- a/tests/build-utils.scm
+++ b/tests/build-utils.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2015, 2016, 2019 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2015, 2016, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
@@ -174,7 +174,7 @@ echo hello world"))
(let ((script-file-name (string-append directory "/foo")))
(call-with-output-file script-file-name
(lambda (port)
- (format port script-contents)))
+ (display script-contents port)))
(chmod script-file-name #o777)
(wrap-script script-file-name
`("GUIX_FOO" prefix ("/some/path"