summaryrefslogtreecommitdiff
path: root/pre-inst-env.in
diff options
context:
space:
mode:
authorMathieu Lirzin <mthl@gnu.org>2016-04-03 18:18:46 +0200
committerMathieu Lirzin <mthl@gnu.org>2016-04-15 00:59:07 +0200
commita1097caa6a30f45661ee510c59bf0e01972cebba (patch)
tree6ffe4997938608d555e5ecddbbdb267226e82246 /pre-inst-env.in
parente66d1f59abc02d60be3328cb511452fec946bbb0 (diff)
downloadguix-patches-a1097caa6a30f45661ee510c59bf0e01972cebba.tar
guix-patches-a1097caa6a30f45661ee510c59bf0e01972cebba.tar.gz
build: Move environment '.in' scripts to 'build-aux' directory.
* pre-inst-env.in: Move to ... * build-aux/pre-inst-env.in: ... here. * test-env.in: Move to ... * build-aux/test-env.in: ... here. * configure.ac (AC_CONFIG_FILES): Adapt to this. Keep the generated scripts in their current location which is $(top_builddir).
Diffstat (limited to 'pre-inst-env.in')
-rw-r--r--pre-inst-env.in71
1 files changed, 0 insertions, 71 deletions
diff --git a/pre-inst-env.in b/pre-inst-env.in
deleted file mode 100644
index fe56da6944..0000000000
--- a/pre-inst-env.in
+++ /dev/null
@@ -1,71 +0,0 @@
-#!/bin/sh
-
-# GNU Guix --- Functional package management for GNU
-# Copyright © 2012, 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
-#
-# This file is part of GNU Guix.
-#
-# GNU Guix is free software; you can redistribute it and/or modify it
-# under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 3 of the License, or (at
-# your option) any later version.
-#
-# GNU Guix is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-# Usage: ./pre-inst-env COMMAND ARG...
-#
-# Run COMMAND in a pre-installation environment. Typical use is
-# "./pre-inst-env guix build hello".
-
-# By default we may end up with absolute directory names that contain '..',
-# which get into $GUILE_LOAD_PATH, leading to '..' in the module file names
-# recorded by Guile. To avoid that, make sure we get a real absolute
-# directory name. Additionally, use '-P' to get the canonical directory name
-# so that Guile's 'relative' %file-port-name-canonicalization can actually
-# work (see <http://bugs.gnu.org/17935>.)
-abs_top_srcdir="`cd "@abs_top_srcdir@" > /dev/null; pwd -P`"
-abs_top_builddir="`cd "@abs_top_builddir@" > /dev/null; pwd -P`"
-
-GUILE_LOAD_COMPILED_PATH="$abs_top_builddir${GUILE_LOAD_COMPILED_PATH:+:}$GUILE_LOAD_COMPILED_PATH"
-GUILE_LOAD_PATH="$abs_top_builddir:$abs_top_srcdir${GUILE_LOAD_PATH:+:}$GUILE_LOAD_PATH"
-export GUILE_LOAD_COMPILED_PATH GUILE_LOAD_PATH
-
-# Define $PATH so that `guix' and friends are easily found.
-
-PATH="$abs_top_builddir/scripts:$abs_top_builddir:$PATH"
-export PATH
-
-# Daemon helpers.
-
-NIX_ROOT_FINDER="$abs_top_builddir/nix/scripts/list-runtime-roots"
-NIX_SUBSTITUTERS="$abs_top_builddir/nix/scripts/substitute"
-NIX_BUILD_HOOK="$abs_top_builddir/nix/scripts/offload"
-NIX_LIBEXEC_DIR="@abs_top_builddir@/nix/scripts" # for 'guix-authenticate'
-
-export NIX_ROOT_FINDER NIX_SUBSTITUTERS \
- NIX_BUILD_HOOK NIX_LIBEXEC_DIR
-
-# The 'guix-register' program.
-GUIX_REGISTER="$abs_top_builddir/guix-register"
-export GUIX_REGISTER
-
-# The following variables need only be defined when compiling Guix
-# modules, but we define them to be on the safe side in case of
-# auto-compilation.
-
-NIX_HASH="@NIX_HASH@"
-export NIX_HASH
-
-# Define $GUIX_UNINSTALLED to prevent `guix' from
-# prepending @guilemoduledir@ to the Guile load paths.
-
-GUIX_UNINSTALLED=1
-export GUIX_UNINSTALLED
-
-exec "$@"