summaryrefslogtreecommitdiff
path: root/po/doc/local.mk
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-12-11 22:18:05 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-12-11 22:18:05 +0100
commitb03e4fd5269897448124a7b61a737802b2c638ee (patch)
treee4eaab1d3076e335c57eea462ff7fda7919f0831 /po/doc/local.mk
parentda3c6a7f19ef1243af725f63c16c8fd92fde33b4 (diff)
parent99aad42138e0895df51e64e1261984f277952516 (diff)
downloadguix-patches-b03e4fd5269897448124a7b61a737802b2c638ee.tar
guix-patches-b03e4fd5269897448124a7b61a737802b2c638ee.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'po/doc/local.mk')
-rw-r--r--po/doc/local.mk11
1 files changed, 10 insertions, 1 deletions
diff --git a/po/doc/local.mk b/po/doc/local.mk
index ca588ea916..6b934d945a 100644
--- a/po/doc/local.mk
+++ b/po/doc/local.mk
@@ -16,9 +16,13 @@
# You should have received a copy of the GNU General Public License
# along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+DOC_PO_FILES= \
+ %D%/guix-manual.de.po \
+ %D%/guix-manual.fr.po
+
EXTRA_DIST = \
%D%/guix-manual.pot \
- %D%/guix-manual.fr.po
+ $(DOC_PO_FILES)
POT_OPTIONS = --package-name "guix" --package-version "$(VERSION)" \
--copyright-holder "Ludovic Courtès" \
@@ -57,3 +61,8 @@ doc-pot-update:
done
msgcat $(addprefix $(srcdir)/po/doc/, $(TMP_POT_FILES)) > $(srcdir)/po/doc/guix-manual.pot
rm -f $(addprefix $(srcdir)/po/doc/, $(TMP_POT_FILES))
+
+doc-po-update: doc-pot-update
+ for f in $(DOC_PO_FILES); do \
+ $(MAKE) "$$f"; \
+ done