summaryrefslogtreecommitdiff
path: root/nix/libutil/xml-writer.hh
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-05-31 14:37:54 +0200
committerLudovic Courtès <ludo@gnu.org>2016-05-31 18:22:14 +0200
commit75abbd0cbe2c42f07fa104f97bd206891eb576ef (patch)
tree00b142a62feffa35baca05fac896e14f10e7fc46 /nix/libutil/xml-writer.hh
parent23aab4ab2cb8464b3c7907c8a164fd5710a24e0e (diff)
downloadguix-patches-75abbd0cbe2c42f07fa104f97bd206891eb576ef.tar
guix-patches-75abbd0cbe2c42f07fa104f97bd206891eb576ef.tar.gz
daemon: Remove unused XML output code.
* nix/local.mk (libutil_a_SOURCES): Remove libutil/xml-writer.cc. (libutil_headers): Remove libutil/xml-writer.hh. * nix/libutil/xml-writer.hh, nix/libutil/xml-writer.cc: Remove.
Diffstat (limited to 'nix/libutil/xml-writer.hh')
-rw-r--r--nix/libutil/xml-writer.hh69
1 files changed, 0 insertions, 69 deletions
diff --git a/nix/libutil/xml-writer.hh b/nix/libutil/xml-writer.hh
deleted file mode 100644
index 3cefe3712c..0000000000
--- a/nix/libutil/xml-writer.hh
+++ /dev/null
@@ -1,69 +0,0 @@
-#pragma once
-
-#include <iostream>
-#include <string>
-#include <list>
-#include <map>
-
-
-namespace nix {
-
-using std::string;
-using std::map;
-using std::list;
-
-
-typedef map<string, string> XMLAttrs;
-
-
-class XMLWriter
-{
-private:
-
- std::ostream & output;
-
- bool indent;
- bool closed;
-
- list<string> pendingElems;
-
-public:
-
- XMLWriter(bool indent, std::ostream & output);
- ~XMLWriter();
-
- void close();
-
- void openElement(const string & name,
- const XMLAttrs & attrs = XMLAttrs());
- void closeElement();
-
- void writeEmptyElement(const string & name,
- const XMLAttrs & attrs = XMLAttrs());
-
-private:
- void writeAttrs(const XMLAttrs & attrs);
-
- void indent_(unsigned int depth);
-};
-
-
-class XMLOpenElement
-{
-private:
- XMLWriter & writer;
-public:
- XMLOpenElement(XMLWriter & writer, const string & name,
- const XMLAttrs & attrs = XMLAttrs())
- : writer(writer)
- {
- writer.openElement(name, attrs);
- }
- ~XMLOpenElement()
- {
- writer.closeElement();
- }
-};
-
-
-}