summaryrefslogtreecommitdiff
path: root/guix
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-14 11:24:10 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-05-31 14:54:16 -0400
commit5d8fb87127beee50671a9506013be541a8b45ea8 (patch)
treebff87cbc2b042dcfc6e3000e6c441a8c6c6cd47a /guix
parent026fca8b5b30aaa584e3c2b8144bf21a882a5edd (diff)
downloadguix-patches-5d8fb87127beee50671a9506013be541a8b45ea8.tar
guix-patches-5d8fb87127beee50671a9506013be541a8b45ea8.tar.gz
gnu: Remove python2-setuptools.
* gnu/packages/python-xyz.scm (python2-setuptools): Delete variable. (python-setuptools)[properties]: Delete field. * gnu/packages/syncthing.scm (syncthing-gtk): Delete commented native input. * guix/lint.scm (check-inputs-should-not-be-an-input-at-all): Remove obsolete entries.
Diffstat (limited to 'guix')
-rw-r--r--guix/lint.scm4
1 files changed, 1 insertions, 3 deletions
diff --git a/guix/lint.scm b/guix/lint.scm
index aa16efe6db..73581b518f 100644
--- a/guix/lint.scm
+++ b/guix/lint.scm
@@ -523,9 +523,7 @@ of a package, and INPUT-NAMES, a list of package specifications such as
;; Emit a warning if some inputs of PACKAGE are likely to should not be
;; an input at all.
(let ((input-names '("python-setuptools"
- "python2-setuptools"
- "python-pip"
- "python2-pip")))
+ "python-pip")))
(map (lambda (input)
(make-warning
package