summaryrefslogtreecommitdiff
path: root/guix
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2022-05-18 14:11:09 -0400
committerLudovic Courtès <ludo@gnu.org>2022-05-22 01:07:54 +0200
commit9885c2fd07a26a48a40e0fda859a1c9ae0b3e973 (patch)
tree580b41df8203faff6e7e04b9360c16c7f1202fb3 /guix
parent796045b2c2989761be2122f24528853171d58110 (diff)
downloadguix-patches-9885c2fd07a26a48a40e0fda859a1c9ae0b3e973.tar
guix-patches-9885c2fd07a26a48a40e0fda859a1c9ae0b3e973.tar.gz
gnu: elm: Support 'elm reactor'.
* gnu/packages/elm.scm (elm): Rename to ... (elm-sans-reactor): ... this new variable. [synopsis, description]: Tweak. (elm): New variable. * guix/build-system/elm.scm (default-elm): Use elm-sans-reactor. * doc/guix.texi (Build Systems)[elm-build-system]: Update accordingly. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'guix')
-rw-r--r--guix/build-system/elm.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/guix/build-system/elm.scm b/guix/build-system/elm.scm
index 293bcbfb64..f5321f811b 100644
--- a/guix/build-system/elm.scm
+++ b/guix/build-system/elm.scm
@@ -101,7 +101,7 @@ given VERSION with sha256 checksum HASH."
"Return the default Elm package for builds."
;; Lazily resolve the binding to avoid a circular dependency.
(let ((elm (resolve-interface '(gnu packages elm))))
- (module-ref elm 'elm)))
+ (module-ref elm 'elm-sans-reactor)))
(define (default-elm-core)
"Return the default elm-core package."