summaryrefslogtreecommitdiff
path: root/guix
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-04-05 22:40:16 +0200
committerLudovic Courtès <ludo@gnu.org>2014-04-05 22:40:16 +0200
commit731b996255fb699cd91699f6cd22de41ebafcdcd (patch)
tree749b63309998feb1bf27033fe1dd28ff2ed35e15 /guix
parent512314d738754eeb513a0d1b8074f635ab4f2f06 (diff)
downloadguix-patches-731b996255fb699cd91699f6cd22de41ebafcdcd.tar
guix-patches-731b996255fb699cd91699f6cd22de41ebafcdcd.tar.gz
hydra: Add 'qemu-image' job.
* build-aux/hydra/demo-os.scm: New file. * Makefile.am (EXTRA_DIST): Add it. * build-aux/hydra/gnu-system.scm (qemu-jobs): New procedure. (hydra-jobs): Use it. * guix/scripts/system.scm (read-operating-system): Export.
Diffstat (limited to 'guix')
-rw-r--r--guix/scripts/system.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/guix/scripts/system.scm b/guix/scripts/system.scm
index 7799ccbc47..823713eada 100644
--- a/guix/scripts/system.scm
+++ b/guix/scripts/system.scm
@@ -28,7 +28,8 @@
#:use-module (srfi srfi-1)
#:use-module (srfi srfi-37)
#:use-module (ice-9 match)
- #:export (guix-system))
+ #:export (guix-system
+ read-operating-system))
(define %user-module
;; Module in which the machine description file is loaded.