summaryrefslogtreecommitdiff
path: root/guix
diff options
context:
space:
mode:
authorCyril Roelandt <tipecaml@gmail.com>2013-10-15 00:14:34 +0200
committerCyril Roelandt <tipecaml@gmail.com>2013-12-15 23:39:43 +0100
commitaf949e8ee7e134e30e559dcfa9cf59a3d28ea350 (patch)
treeb7c26a97dfbcd6d663f6ca7f306301e59584db3c /guix
parent503c5f6d5d5b61097731158e70ff598fe42d6345 (diff)
downloadguix-patches-af949e8ee7e134e30e559dcfa9cf59a3d28ea350.tar
guix-patches-af949e8ee7e134e30e559dcfa9cf59a3d28ea350.tar.gz
gnu: gtk+: enable introspection.
* gnu/packages/gtk.scm (atk, gdk-pixbuf, gtk+, pango): enable introspection * guix/build/gnome.scm: New file.
Diffstat (limited to 'guix')
-rw-r--r--guix/build/gnome.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/guix/build/gnome.scm b/guix/build/gnome.scm
new file mode 100644
index 0000000000..cac4de8f24
--- /dev/null
+++ b/guix/build/gnome.scm
@@ -0,0 +1,31 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (guix build gnome)
+ #:export (gir-directory))
+
+;;; Commentary:
+;;;
+;;; Tools commonly used when building GNOME programs.
+;;;
+;;; Code:
+
+(define (gir-directory inputs pkg-name)
+ "Return the GIR directory name for PKG-NAME found from INPUTS."
+ (string-append (assoc-ref inputs pkg-name)
+ "/share/gir-1.0"))