summaryrefslogtreecommitdiff
path: root/guix
diff options
context:
space:
mode:
authorThiago Jung Bauermann <bauermann@kolabnow.com>2021-07-04 21:00:59 -0300
committerLudovic Courtès <ludo@gnu.org>2021-07-21 15:55:26 +0200
commit04e80290bf1023f83649f807ddcd4d980da1747b (patch)
tree4048ef8031f451dccd3a80bf4316698fa533ad4f /guix
parent777962de5ec4a8b0d57fcd745cf6e4b05689b582 (diff)
downloadguix-patches-04e80290bf1023f83649f807ddcd4d980da1747b.tar
guix-patches-04e80290bf1023f83649f807ddcd4d980da1747b.tar.gz
gnu: TeX Live: Use IniTeX to build a couple of packages
The package texlive-latex-base in TeX Live 2021 will depend on texlive-latex-l3kernel and texlive-latex-l3packages. Therefore we need to remove their build dependency on texlive-latex-base to avoid a circular dependency. l3kernel and l3packages don’t need LaTeX during build, just IniTeX. So to make them use it, modify texlive-build-system to allow disabling the #:texlive-latex-base and #:tex-format parameters, and also add a #:tex-engine parameter. We also need to add texlive-docstrip as a native input, which was previously provided by texlive-latex-base. * gnu/packages/tex.scm (texlive-latex-l3kernel, texlive-latex-l3packages)[arguments]: Add ‘#:tex-engine’, ‘#:tex-format’ and ‘#:texlive-latex-base’ parameters. [native-inputs]: Add ‘texlive-docstrip’. * guix/build-system/texlive.scm (lower)[build-inputs]: Don’t add ‘texlive-latex-base’ if its keyword parameter is false. (texlive-build): Add ‘tex-engine’ keyword parameter. [builder]: If a ‘tex-engine’ parameter was passed, use it. Otherwise, use ‘tex-format’ as the engine. * guix/build/texlive-build-system.scm (compile-with-latex): Add ‘engine’ parameter. If the ‘format’ parameter is false, add “-ini” option to the command line. (build): Add ‘tex-engine’ parameter. Pass it down to ‘compile-with-latex’. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'guix')
-rw-r--r--guix/build-system/texlive.scm9
-rw-r--r--guix/build/texlive-build-system.scm12
2 files changed, 15 insertions, 6 deletions
diff --git a/guix/build-system/texlive.scm b/guix/build-system/texlive.scm
index 005aad819e..f3838e580a 100644
--- a/guix/build-system/texlive.scm
+++ b/guix/build-system/texlive.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2021 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2021 Thiago Jung Bauermann <bauermann@kolabnow.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -116,7 +117,9 @@ level package ID."
;; Keep the standard inputs of 'gnu-build-system'.
,@(standard-packages)))
(build-inputs `(("texlive-bin" ,texlive-bin)
- ("texlive-latex-base" ,texlive-latex-base)
+ ,@(if texlive-latex-base
+ `(("texlive-latex-base" ,texlive-latex-base))
+ '())
,@native-inputs))
(outputs outputs)
(build texlive-build)
@@ -128,6 +131,7 @@ level package ID."
(tests? #f)
tex-directory
(build-targets #f)
+ (tex-engine #f)
;; FIXME: This would normally default to "luatex" but
;; LuaTeX has a bug where sometimes it corrupts the
@@ -158,6 +162,9 @@ level package ID."
#:source #+source
#:tex-directory #$tex-directory
#:build-targets #$build-targets
+ #:tex-engine #$(if tex-engine
+ tex-engine
+ tex-format)
#:tex-format #$tex-format
#:system #$system
#:tests? #$tests?
diff --git a/guix/build/texlive-build-system.scm b/guix/build/texlive-build-system.scm
index 4c255700bb..353fb934a6 100644
--- a/guix/build/texlive-build-system.scm
+++ b/guix/build/texlive-build-system.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2021 Thiago Jung Bauermann <bauermann@kolabnow.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -34,16 +35,17 @@
;;
;; Code:
-(define (compile-with-latex format file)
- (invoke format
+(define (compile-with-latex engine format file)
+ (invoke engine
"-interaction=nonstopmode"
"-output-directory=build"
- (string-append "&" format)
+ (if format (string-append "&" format) "-ini")
file))
-(define* (build #:key inputs build-targets tex-format #:allow-other-keys)
+(define* (build #:key inputs build-targets tex-engine tex-format
+ #:allow-other-keys)
(mkdir "build")
- (for-each (cut compile-with-latex tex-format <>)
+ (for-each (cut compile-with-latex tex-engine tex-format <>)
(if build-targets build-targets
(scandir "." (cut string-suffix? ".ins" <>)))))