summaryrefslogtreecommitdiff
path: root/guix
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-06-11 02:07:06 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-06-11 02:07:06 +0200
commit5bace4c8ad981b66b5c0769b885d0bb0db91a029 (patch)
tree0f2fb95c23d7990d26aeed71590bb94a3f2e17fe /guix
parent653569e878f39345b05110b998f10db3b520ccfe (diff)
parent20d87dfb453cf27f95c5ef3858e8d096278e1702 (diff)
downloadguix-patches-5bace4c8ad981b66b5c0769b885d0bb0db91a029.tar
guix-patches-5bace4c8ad981b66b5c0769b885d0bb0db91a029.tar.gz
Merge branch 'master' into core-updates
Conflicts: * gnu/packages/tls.scm (gnutls): Incorporated 3.5.13 graft (88e2511e217f2).
Diffstat (limited to 'guix')
-rw-r--r--guix/scripts/system.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/guix/scripts/system.scm b/guix/scripts/system.scm
index f71b1d71b8..35675cc018 100644
--- a/guix/scripts/system.scm
+++ b/guix/scripts/system.scm
@@ -425,7 +425,7 @@ generation as its default entry. STORE is an open connection to the store."
"Return the bootloader name stored in SYSTEM's \"parameters\" file."
(let ((params (unless-file-not-found
(read-boot-parameters-file system))))
- (boot-parameters-boot-name params)))
+ (boot-parameters-bootloader-name params)))
(define (reinstall-bootloader store number)
"Re-install bootloader for existing system profile generation NUMBER.
@@ -521,7 +521,7 @@ list of services."
(let* ((generation (generation-file-name profile number))
(params (read-boot-parameters-file generation))
(label (boot-parameters-label params))
- (boot-name (boot-parameters-boot-name params))
+ (bootloader-name (boot-parameters-bootloader-name params))
(root (boot-parameters-root-device params))
(root-device (if (bytevector? root)
(uuid->string root)
@@ -532,7 +532,7 @@ list of services."
(format #t (G_ " canonical file name: ~a~%") (readlink* generation))
;; TRANSLATORS: Please preserve the two-space indentation.
(format #t (G_ " label: ~a~%") label)
- (format #t (G_ " bootloader: ~a~%") boot-name)
+ (format #t (G_ " bootloader: ~a~%") bootloader-name)
(format #t (G_ " root device: ~a~%") root-device)
(format #t (G_ " kernel: ~a~%") kernel))))