summaryrefslogtreecommitdiff
path: root/guix
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-10-03 20:12:59 +0200
committerLudovic Courtès <ludo@gnu.org>2015-10-04 00:10:03 +0200
commitafd3d9316ce3c48cd7f7dbae64be0f8bcb756ba6 (patch)
treee53fe41f65e71aae9257aa37d8e1fd9ad6706439 /guix
parent8a55e217ad3a6af96f9e05eb676616224fde509f (diff)
downloadguix-patches-afd3d9316ce3c48cd7f7dbae64be0f8bcb756ba6.tar
guix-patches-afd3d9316ce3c48cd7f7dbae64be0f8bcb756ba6.tar.gz
Use "normalized codesets" everywhere.
In other words, change "xx_YY.UTF-8" to "xx_YY.utf8". * guix/profiles.scm (ca-certificate-bundle): Use "en_US.utf8" instead of "en_US.UTF-8". * guix/packages.scm (patch-and-repack): Likewise. * guix/build/gnu-build-system.scm (install-locale): Likewise. * guix/build-system/gnu.scm (gnu-build, gnu-cross-build): Likewise. * gnu/packages/python.scm (python-ipython): Likewise. * gnu/packages/gawk.scm (gawk): Likewise. * build-aux/hydra/demo-os.scm: Likewise. * gnu/packages/guile.scm (guile-ncurses)[arguments]: Remove 'change-locale' phase.
Diffstat (limited to 'guix')
-rw-r--r--guix/build-system/gnu.scm4
-rw-r--r--guix/build/gnu-build-system.scm2
-rw-r--r--guix/packages.scm2
-rw-r--r--guix/profiles.scm2
4 files changed, 5 insertions, 5 deletions
diff --git a/guix/build-system/gnu.scm b/guix/build-system/gnu.scm
index 1f302447c2..3be83468eb 100644
--- a/guix/build-system/gnu.scm
+++ b/guix/build-system/gnu.scm
@@ -287,7 +287,7 @@ standard packages used as implicit inputs of the GNU build system."
"bin" "sbin"))
(validate-runpath? #t)
(phases '%standard-phases)
- (locale "en_US.UTF-8")
+ (locale "en_US.utf8")
(system (%current-system))
(build (nix-system->gnu-triplet system))
(imported-modules %gnu-build-system-modules)
@@ -422,7 +422,7 @@ is one of `host' or `target'."
"bin" "sbin"))
(validate-runpath? #t)
(phases '%standard-phases)
- (locale "en_US.UTF-8")
+ (locale "en_US.utf8")
(system (%current-system))
(build (nix-system->gnu-triplet system))
(imported-modules %gnu-build-system-modules)
diff --git a/guix/build/gnu-build-system.scm b/guix/build/gnu-build-system.scm
index 75439c8330..ff7646b22c 100644
--- a/guix/build/gnu-build-system.scm
+++ b/guix/build/gnu-build-system.scm
@@ -99,7 +99,7 @@
#t)
(define* (install-locale #:key
- (locale "en_US.UTF-8")
+ (locale "en_US.utf8")
(locale-category LC_ALL)
#:allow-other-keys)
"Try to install LOCALE; emit a warning if that fails. The main goal is to
diff --git a/guix/packages.scm b/guix/packages.scm
index 72822b8c97..622cb0ac0c 100644
--- a/guix/packages.scm
+++ b/guix/packages.scm
@@ -478,7 +478,7 @@ IMPORTED-MODULES specify modules to use/import for use by SNIPPET."
;; First of all, install a UTF-8 locale so that UTF-8 file names
;; are correctly interpreted. During bootstrap, LOCALES is #f.
(setenv "LOCPATH" (string-append #+locales "/lib/locale"))
- (setlocale LC_ALL "en_US.UTF-8"))
+ (setlocale LC_ALL "en_US.utf8"))
(setenv "PATH" (string-append #+xz "/bin" ":"
#+decomp "/bin"))
diff --git a/guix/profiles.scm b/guix/profiles.scm
index c56ebb145b..fac322bbab 100644
--- a/guix/profiles.scm
+++ b/guix/profiles.scm
@@ -576,7 +576,7 @@ MANIFEST. Single-file bundles are required by programs such as Git and Lynx."
(setenv "LOCPATH"
(string-append #+glibc-utf8-locales "/lib/locale/"
#+(package-version glibc-utf8-locales)))
- (setlocale LC_ALL "en_US.UTF-8")
+ (setlocale LC_ALL "en_US.utf8")
(match (append-map ca-files '#$(manifest-inputs manifest))
(()