summaryrefslogtreecommitdiff
path: root/guix/store.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-12-05 23:02:47 +0100
committerLudovic Courtès <ludo@gnu.org>2012-12-06 00:07:17 +0100
commitd8eea3d2bce9c9e834210237090947de4600cfe8 (patch)
tree5572df7de406f06b31f6be7d68526f69208442b1 /guix/store.scm
parent69cfce50dbb2000c5f5d98f0f364fe324004bf99 (diff)
downloadguix-patches-d8eea3d2bce9c9e834210237090947de4600cfe8.tar
guix-patches-d8eea3d2bce9c9e834210237090947de4600cfe8.tar.gz
build: Capture configure-time settings in (guix config).
* configure.ac: Compute and substitute `guix_localstatedir'. * m4/guix.m4: Substitute `guix_system'. * guix/config.scm.in (%store-directory, %store-directory, %system): New variables. * guix/store.scm (%nix-state-dir): Remove. (%default-socket-path): Use %STATE-DIRECTORY as the default. (%store-prefix): Use %STORE-DIRECTORY as the default. * guix/utils.scm (%current-system): Default to %SYSTEM.
Diffstat (limited to 'guix/store.scm')
-rw-r--r--guix/store.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/guix/store.scm b/guix/store.scm
index 9aafb332dc..3bfb03e6b5 100644
--- a/guix/store.scm
+++ b/guix/store.scm
@@ -18,6 +18,7 @@
(define-module (guix store)
#:use-module (guix utils)
+ #:use-module (guix config)
#:use-module (rnrs bytevectors)
#:use-module (rnrs io ports)
#:use-module (srfi srfi-1)
@@ -111,10 +112,9 @@
(sha1 2)
(sha256 3))
-(define %nix-state-dir
- (or (getenv "NIX_STATE_DIR") "/nix/var/nix"))
(define %default-socket-path
- (string-append %nix-state-dir "/daemon-socket/socket"))
+ (string-append (or (getenv "NIX_STATE_DIR") %state-directory)
+ "/daemon-socket/socket"))
;; serialize.cc
@@ -439,7 +439,7 @@ file name. Return #t on success."
(define %store-prefix
;; Absolute path to the Nix store.
(make-parameter (or (and=> (getenv "NIX_STORE_DIR") canonicalize-path)
- "/nix/store")))
+ %store-directory)))
(define (store-path? path)
"Return #t if PATH is a store path."