summaryrefslogtreecommitdiff
path: root/guix/snix.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-11-12 23:10:26 +0100
committerLudovic Courtès <ludo@gnu.org>2012-11-12 23:35:04 +0100
commit62cab99c3297a066f466780bb4d83a4f142538c7 (patch)
treed17374f770ad043356b915967f8960ab9f8cc7c0 /guix/snix.scm
parentddc29a782eac30fcf4ff1f07677aa2896dc140e4 (diff)
downloadguix-patches-62cab99c3297a066f466780bb4d83a4f142538c7.tar
guix-patches-62cab99c3297a066f466780bb4d83a4f142538c7.tar.gz
Add (guix download) and (guix build download).
* guix/download.scm, guix/build/download.scm: New files. * Makefile.am (MODULES): Add them. * tests/builders.scm ("url-fetch"): New test. * distro/packages/bootstrap.scm (bootstrap-origin): Support `url-fetch'. * guix/snix.scm (snix-derivation->guix-package): Use `url-fetch' instead of `http-fetch'.
Diffstat (limited to 'guix/snix.scm')
-rw-r--r--guix/snix.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/guix/snix.scm b/guix/snix.scm
index c6a9bee6a7..a5b8447470 100644
--- a/guix/snix.scm
+++ b/guix/snix.scm
@@ -400,7 +400,7 @@ location of DERIVATION."
(name ,name)
(version ,version)
(source (origin
- (method http-fetch)
+ (method url-fetch)
(uri ,(pretty-uri (car urls) version))
(sha256
(base32