summaryrefslogtreecommitdiff
path: root/guix/scripts/package.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-06-13 17:30:40 +0200
committerLudovic Courtès <ludo@gnu.org>2014-06-13 17:30:40 +0200
commitee76417972b3a749a28a627c2858c09311d9c0c5 (patch)
treeb47f7f0959763d3b445bf5dbd11025c2e4480b1f /guix/scripts/package.scm
parentef1a9bb7d6fd64f05607042fdb266ee974d16e26 (diff)
downloadguix-patches-ee76417972b3a749a28a627c2858c09311d9c0c5.tar
guix-patches-ee76417972b3a749a28a627c2858c09311d9c0c5.tar.gz
Separate package description translations from string translations.
* po/packages/LINGUAS, po/packages/Makevars, po/packages/POTFILES.in: New files. * po/guix/Makevars (DOMAIN): Change to "guix". (XGETTEXT_OPTIONS): Remove "--keyword=synopsis --keyword=description". * po/guix/POTFILES.in: Remove gnu/packages/*.scm. * configure.ac: Change to gettext 0.18.3. Produce po/packages/Makefile.in. * Makefile.am (SUBDIRS): Add po/packages. * guix/ui.scm (%package-text-domain): New variable. (P_): New procedure. (package->recutils): Use 'P_' instead of '_'. * guix/scripts/package.scm (find-packages-by-description): Use 'P_' instead of 'gettext'.
Diffstat (limited to 'guix/scripts/package.scm')
-rw-r--r--guix/scripts/package.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/guix/scripts/package.scm b/guix/scripts/package.scm
index 3947159c2e..f930b00804 100644
--- a/guix/scripts/package.scm
+++ b/guix/scripts/package.scm
@@ -228,11 +228,11 @@ RX."
(define matches?
(cut regexp-exec rx <>))
- (if (or (matches? (gettext (package-name package)))
+ (if (or (matches? (package-name package))
(and=> (package-synopsis package)
- (compose matches? gettext))
+ (compose matches? P_))
(and=> (package-description package)
- (compose matches? gettext)))
+ (compose matches? P_)))
(cons package result)
result))
'())