summaryrefslogtreecommitdiff
path: root/guix/scripts/pack.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-11-17 18:00:28 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-11-17 18:00:28 -0500
commit129b9b16d9b588316cc997cf8f4fefe30961a417 (patch)
treebc1dc50e83af6e9afb2ee24cd32f5e42e039642e /guix/scripts/pack.scm
parent5f9c92dd6285a1ef326cf5aa99781f1f3acbd245 (diff)
parent9113de2ca2db195908e3262b3752f8392ada8630 (diff)
downloadguix-patches-129b9b16d9b588316cc997cf8f4fefe30961a417.tar
guix-patches-129b9b16d9b588316cc997cf8f4fefe30961a417.tar.gz
Merge remote-tracking branch 'origin/version-1.2.0' into master
Conflicts: gnu/packages/bioinformatics.scm The python-pysam package fixed in master was kept instead of the update done in the version-1.2.0 branch.
Diffstat (limited to 'guix/scripts/pack.scm')
-rw-r--r--guix/scripts/pack.scm5
1 files changed, 5 insertions, 0 deletions
diff --git a/guix/scripts/pack.scm b/guix/scripts/pack.scm
index 06509ace2d..0b29997200 100644
--- a/guix/scripts/pack.scm
+++ b/guix/scripts/pack.scm
@@ -59,11 +59,16 @@
#:use-module (srfi srfi-37)
#:use-module (ice-9 match)
#:export (compressor?
+ compressor-name
+ compressor-extenstion
+ compressor-command
+ %compressors
lookup-compressor
self-contained-tarball
docker-image
squashfs-image
+ %formats
guix-pack))
;; Type of a compression tool.