summaryrefslogtreecommitdiff
path: root/guix/scripts/edit.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-06-17 21:58:04 +0200
committerLudovic Courtès <ludo@gnu.org>2015-06-18 00:25:49 +0200
commit39bee8a2937ea28e74b5c807962fb8bc87fe6887 (patch)
treeb4141bbc425ef3d788d1cf4827ccb4dbe86f1620 /guix/scripts/edit.scm
parent84189ebc66266f03b9ca7e8b912d529886436851 (diff)
downloadguix-patches-39bee8a2937ea28e74b5c807962fb8bc87fe6887.tar
guix-patches-39bee8a2937ea28e74b5c807962fb8bc87fe6887.tar.gz
Add 'guix edit'.
* guix/scripts/edit.scm: New file. * Makefile.am (MODULES): Add it. * doc.am (SUBCOMMANDS): Add 'edit'. * doc/guix.texi (Defining Packages): Add xref to "Invoking guix edit". (Invoking guix edit): New node. * po/guix/POTFILES.in: Add it.
Diffstat (limited to 'guix/scripts/edit.scm')
-rw-r--r--guix/scripts/edit.scm79
1 files changed, 79 insertions, 0 deletions
diff --git a/guix/scripts/edit.scm b/guix/scripts/edit.scm
new file mode 100644
index 0000000000..fc453ac38d
--- /dev/null
+++ b/guix/scripts/edit.scm
@@ -0,0 +1,79 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2015 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (guix scripts edit)
+ #:use-module (guix ui)
+ #:use-module (guix utils)
+ #:use-module (guix packages)
+ #:use-module (gnu packages)
+ #:use-module (srfi srfi-1)
+ #:use-module (srfi srfi-37)
+ #:export (%editor
+ guix-edit))
+
+(define %options
+ (list (option '(#\h "help") #f #f
+ (lambda args
+ (show-help)
+ (exit 0)))
+ (option '(#\V "version") #f #f
+ (lambda args
+ (show-version-and-exit "guix edit")))))
+
+(define (show-help)
+ (display (_ "Usage: guix edit PACKAGE...
+Start $EDITOR to edit the definitions of PACKAGE...\n"))
+ (newline)
+ (display (_ "
+ -h, --help display this help and exit"))
+ (display (_ "
+ -V, --version display version information and exit"))
+ (newline)
+ (show-bug-report-information))
+
+(define %editor
+ (make-parameter (or (getenv "EDITOR") "emacsclient")))
+
+(define (search-path* path file)
+ "Like 'search-path' but exit if FILE is not found."
+ (let ((absolute-file-name (search-path path file)))
+ (unless absolute-file-name
+ ;; Shouldn't happen unless somebody fiddled with the 'location' field.
+ (leave (_ "file '~a' not found in search path ~s~%")
+ file path))
+ absolute-file-name))
+
+
+(define (guix-edit . args)
+ (with-error-handling
+ (let* ((specs (parse-command-line args %options '(())
+ #:argument-handler cons))
+ (packages (map specification->package specs)))
+ (for-each (lambda (package)
+ (unless (package-location package)
+ (leave (_ "source location of package '~a' is unknown~%")
+ (package-full-name package))))
+ packages)
+ (apply execlp (%editor) (%editor)
+ (append-map (lambda (package)
+ (let ((loc (package-location package)))
+ (list (string-append "+"
+ (number->string
+ (location-line loc)))
+ (search-path* %load-path (location-file loc)))))
+ packages)))))