summaryrefslogtreecommitdiff
path: root/guix/import/egg.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-06-23 18:45:21 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-06-23 18:45:21 +0200
commit9dea3f101f252331c049c03f501398a5ec837ba9 (patch)
tree61d683a9fae3e147332d07fef207c1ddf51fc301 /guix/import/egg.scm
parent7f0af119a1e3ea9d0ae53811b619437b3e942702 (diff)
parent620669fd17306c2edb21c64a99fa47160fefb319 (diff)
downloadguix-patches-9dea3f101f252331c049c03f501398a5ec837ba9.tar
guix-patches-9dea3f101f252331c049c03f501398a5ec837ba9.tar.gz
Merge branch 'master' into core-updates
Conflicts: gnu/packages/cups.scm gnu/packages/python-web.scm gnu/packages/web.scm guix/build/maven/pom.scm
Diffstat (limited to 'guix/import/egg.scm')
-rw-r--r--guix/import/egg.scm12
1 files changed, 8 insertions, 4 deletions
diff --git a/guix/import/egg.scm b/guix/import/egg.scm
index 26f8364732..107894ddcf 100644
--- a/guix/import/egg.scm
+++ b/guix/import/egg.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2021 Xinglu Chen <public@yoctocell.xyz>
+;;; Copyright © 2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -173,10 +174,13 @@ return the package metadata in FILE."
;;;
(define* (egg->guix-package name #:key (file #f) (source #f))
- "Import CHICKEN egg NAME from and return a <package> record type for the
-egg, or #f on failure. FILE is the filepath to the NAME.egg file. SOURCE is
-the a ``file-like'' object containing the source code corresonding to the egg.
-If SOURCE is not specified, the tarball for the egg will be downloaded.
+ "Import a CHICKEN egg called NAME from either the given .egg FILE, or from
+the latest NAME metadata downloaded from the official repository if FILE is #f.
+Return a <package> record or #f on failure.
+
+SOURCE is a ``file-like'' object containing the source code corresponding to
+the egg. If SOURCE is not specified, the latest tarball for egg NAME will be
+downloaded.
Specifying the SOURCE argument is mainly useful for developing a CHICKEN egg
locally. Note that if FILE and SOURCE are specified, recursive import will