summaryrefslogtreecommitdiff
path: root/guix/graph.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-01-04 22:10:49 +0100
committerLudovic Courtès <ludo@gnu.org>2021-01-04 23:54:16 +0100
commit10612d61540228d48c998ba5b56f50da22534157 (patch)
tree7ac40f6a244fbd9e95bcbb94330b5d8c6d22965c /guix/graph.scm
parentfa42774742fb1ddcb9f9424d8150d26f4033d426 (diff)
downloadguix-patches-10612d61540228d48c998ba5b56f50da22534157.tar
guix-patches-10612d61540228d48c998ba5b56f50da22534157.tar.gz
graph: Install JavaScript files.
Until now, 'guix graph --backend=d3js' wouldn't work outside the build tree. * d3.v3.js: Move to... * guix/d3.v3.js: ... here. * graph.js: Move to... * guix/graph.js: ... here. * Makefile.am (nobase_dist_guilemodule_DATA): Add them. (EXTRA_DIST): Remove them. * guix/graph.scm (emit-d3js-prologue, emit-d3js-epilogue): Adjust 'search-path' argument accordingly. * guix/self.scm (compiled-guix)[*extra-modules*]: Pass them via #:extra-files.
Diffstat (limited to 'guix/graph.scm')
-rw-r--r--guix/graph.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/guix/graph.scm b/guix/graph.scm
index 93ff9ef81a..0d4cd83667 100644
--- a/guix/graph.scm
+++ b/guix/graph.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2015, 2016, 2020 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2015, 2016, 2020, 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
@@ -274,11 +274,11 @@ text {
var nodes = {},
nodeArray = [],
links = [];
-" (search-path %load-path "d3.v3.js")))
+" (search-path %load-path "guix/d3.v3.js")))
(define (emit-d3js-epilogue port)
(format port "</script><script type=\"text/javascript\" src=\"~a\"></script></body></html>"
- (search-path %load-path "graph.js")))
+ (search-path %load-path "guix/graph.js")))
(define (emit-d3js-node id label port)
(format port "\