summaryrefslogtreecommitdiff
path: root/guix/graph.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-11-07 21:33:32 +0100
committerMarius Bakke <marius@gnu.org>2020-11-07 21:33:32 +0100
commit32787d652460871a79f99b63230f92759e2e0de2 (patch)
treece883cac0d602b10b7c005755d035a08197e73a9 /guix/graph.scm
parent052939c2f6e36de00a5e756ea29a4cc96884a55d (diff)
parentc2396ceb6eb30ac87755eb8b39583403b35fbd12 (diff)
downloadguix-patches-32787d652460871a79f99b63230f92759e2e0de2.tar
guix-patches-32787d652460871a79f99b63230f92759e2e0de2.tar.gz
Merge branch 'master' into staging
Conflicts: gnu/local.mk gnu/packages/gdb.scm gnu/packages/lisp-xyz.scm gnu/packages/web-browsers.scm
Diffstat (limited to 'guix/graph.scm')
-rw-r--r--guix/graph.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/guix/graph.scm b/guix/graph.scm
index b695ca4306..93ff9ef81a 100644
--- a/guix/graph.scm
+++ b/guix/graph.scm
@@ -142,7 +142,7 @@ typically returned by 'node-edges' or 'node-back-edges'."
nodes node-edges))
(define (shortest-path node1 node2 type)
- "Return as a monadic value the shorted path, represented as a list, from
+ "Return as a monadic value the shortest path, represented as a list, from
NODE1 to NODE2 of the given TYPE. Return #f when there is no path."
(define node-edges
(node-type-edges type))
@@ -238,7 +238,7 @@ NODE1 to NODE2 of the given TYPE. Return #f when there is no path."
(define (emit-epilogue port)
(display "\n}\n" port))
(define (emit-node id label port)
- (format port " \"~a\" [label = \"~a\", shape = box, fontname = Helvetica];~%"
+ (format port " \"~a\" [label = \"~a\", shape = box, fontname = sans];~%"
id label))
(define (emit-edge id1 id2 port)
(format port " \"~a\" -> \"~a\" [color = ~a];~%"