summaryrefslogtreecommitdiff
path: root/guix/download.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-11-12 23:10:26 +0100
committerLudovic Courtès <ludo@gnu.org>2012-11-12 23:35:04 +0100
commit62cab99c3297a066f466780bb4d83a4f142538c7 (patch)
treed17374f770ad043356b915967f8960ab9f8cc7c0 /guix/download.scm
parentddc29a782eac30fcf4ff1f07677aa2896dc140e4 (diff)
downloadguix-patches-62cab99c3297a066f466780bb4d83a4f142538c7.tar
guix-patches-62cab99c3297a066f466780bb4d83a4f142538c7.tar.gz
Add (guix download) and (guix build download).
* guix/download.scm, guix/build/download.scm: New files. * Makefile.am (MODULES): Add them. * tests/builders.scm ("url-fetch"): New test. * distro/packages/bootstrap.scm (bootstrap-origin): Support `url-fetch'. * guix/snix.scm (snix-derivation->guix-package): Use `url-fetch' instead of `http-fetch'.
Diffstat (limited to 'guix/download.scm')
-rw-r--r--guix/download.scm73
1 files changed, 73 insertions, 0 deletions
diff --git a/guix/download.scm b/guix/download.scm
new file mode 100644
index 0000000000..b5e8c675ac
--- /dev/null
+++ b/guix/download.scm
@@ -0,0 +1,73 @@
+;;; Guix --- Nix package management from Guile. -*- coding: utf-8 -*-
+;;; Copyright (C) 2012 Ludovic Courtès <ludo@gnu.org>
+;;;
+;;; This file is part of Guix.
+;;;
+;;; Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (guix download)
+ #:use-module (ice-9 match)
+ #:use-module (guix derivations)
+ #:use-module (guix packages)
+ #:use-module ((guix store) #:select (derivation-path?))
+ #:use-module (guix utils)
+ #:export (url-fetch))
+
+;;; Commentary:
+;;;
+;;; Produce fixed-output derivations with data fetched over HTTP or FTP.
+;;;
+;;; Code:
+
+(define* (url-fetch store url hash-algo hash
+ #:optional name
+ #:key (system (%current-system)) guile)
+ "Return the path of a fixed-output derivation in STORE that fetches
+URL (a string, or a list of strings denoting alternate URLs), which is
+expected to have hash HASH of type HASH-ALGO (a symbol). By default,
+the file name is the base name of URL; optionally, NAME can specify a
+different file name."
+ (define builder
+ `(begin
+ (use-modules (guix build download))
+ (url-fetch ',url %output)))
+
+ (define guile-for-build
+ (match guile
+ ((? package?)
+ (package-derivation store guile system))
+ ((and (? string?) (? derivation-path?))
+ guile)
+ (#f ; the default
+ (let* ((distro (resolve-interface '(distro packages base)))
+ (guile (module-ref distro 'guile-final)))
+ (package-derivation store guile system)))))
+
+ (define file-name
+ (match url
+ ((head _ ...)
+ (basename head))
+ (_
+ (basename url))))
+
+ (build-expression->derivation store (or name file-name) system
+ builder '()
+ #:hash-algo hash-algo
+ #:hash hash
+ #:modules '((guix build download)
+ (guix build utils)
+ (guix ftp-client))
+ #:guile-for-build guile-for-build))
+
+;;; download.scm ends here