summaryrefslogtreecommitdiff
path: root/guix/build
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-09-01 23:13:56 +0200
committerLudovic Courtès <ludo@gnu.org>2013-09-02 00:20:14 +0200
commitd91712ee894e3bcaabc51269d292cbe77ed89530 (patch)
tree13f3e5e6daaf435cf9bc16f0303ae944c766ed50 /guix/build
parentd9ff410fb279571826748dac51adc00379968bbc (diff)
downloadguix-patches-d91712ee894e3bcaabc51269d292cbe77ed89530.tar
guix-patches-d91712ee894e3bcaabc51269d292cbe77ed89530.tar.gz
gnu: linux-initrd: Factorize device node creation.
* guix/build/linux-initrd.scm (make-essential-device-nodes): New procedure. * gnu/packages/linux-initrd.scm (qemu-initrd): Use it.
Diffstat (limited to 'guix/build')
-rw-r--r--guix/build/linux-initrd.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/guix/build/linux-initrd.scm b/guix/build/linux-initrd.scm
index 81f9e46cfb..208ad711ef 100644
--- a/guix/build/linux-initrd.scm
+++ b/guix/build/linux-initrd.scm
@@ -21,6 +21,7 @@
#:use-module (system foreign)
#:export (mount-essential-file-systems
linux-command-line
+ make-essential-device-nodes
configure-qemu-networking
mount-qemu-smb-share
bind-mount
@@ -59,6 +60,37 @@
(call-with-input-file "/proc/cmdline"
get-string-all)))
+(define* (make-essential-device-nodes #:key (root "/"))
+ "Make essential device nodes under ROOT/dev."
+ ;; The hand-made udev!
+
+ (define (scope dir)
+ (string-append root
+ (if (string-suffix? "/" root)
+ ""
+ "/")
+ dir))
+
+ (unless (file-exists? (scope "dev"))
+ (mkdir (scope "dev")))
+
+ ;; Make the device nodes for QEMU's hard disk and partitions.
+ (mknod (scope "dev/vda") 'block-special #o644 (device-number 8 0))
+ (mknod (scope "dev/vda1") 'block-special #o644 (device-number 8 1))
+ (mknod (scope "dev/vda2") 'block-special #o644 (device-number 8 2))
+
+ ;; TTYs.
+ (let loop ((n 0))
+ (and (< n 50)
+ (let ((name (format #f "dev/tty~a" n)))
+ (mknod (scope name) 'block-special #o644
+ (device-number 4 n))
+ (loop (+ 1 n)))))
+
+ ;; Other useful nodes.
+ (mknod (scope "dev/null") 'char-special #o666 (device-number 1 3))
+ (mknod (scope "dev/zero") 'char-special #o666 (device-number 1 5)))
+
(define %host-qemu-ipv4-address
(inet-pton AF_INET "10.0.2.10"))