summaryrefslogtreecommitdiff
path: root/guix/build
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-11-07 21:33:32 +0100
committerMarius Bakke <marius@gnu.org>2020-11-07 21:33:32 +0100
commit32787d652460871a79f99b63230f92759e2e0de2 (patch)
treece883cac0d602b10b7c005755d035a08197e73a9 /guix/build
parent052939c2f6e36de00a5e756ea29a4cc96884a55d (diff)
parentc2396ceb6eb30ac87755eb8b39583403b35fbd12 (diff)
downloadguix-patches-32787d652460871a79f99b63230f92759e2e0de2.tar
guix-patches-32787d652460871a79f99b63230f92759e2e0de2.tar.gz
Merge branch 'master' into staging
Conflicts: gnu/local.mk gnu/packages/gdb.scm gnu/packages/lisp-xyz.scm gnu/packages/web-browsers.scm
Diffstat (limited to 'guix/build')
-rw-r--r--guix/build/maven-build-system.scm3
-rw-r--r--guix/build/maven/pom.scm12
2 files changed, 8 insertions, 7 deletions
diff --git a/guix/build/maven-build-system.scm b/guix/build/maven-build-system.scm
index 914298d584..534b4ebcee 100644
--- a/guix/build/maven-build-system.scm
+++ b/guix/build/maven-build-system.scm
@@ -100,7 +100,8 @@
inputs local-packages excludes)))))))
(define* (fix-pom-files #:key inputs local-packages exclude #:allow-other-keys)
- (fix-pom "pom.xml" inputs local-packages exclude))
+ (fix-pom "pom.xml" inputs local-packages exclude)
+ #t)
(define* (build #:key outputs #:allow-other-keys)
"Build the given package."
diff --git a/guix/build/maven/pom.scm b/guix/build/maven/pom.scm
index aa60af2afa..c92d409d2b 100644
--- a/guix/build/maven/pom.scm
+++ b/guix/build/maven/pom.scm
@@ -59,7 +59,7 @@ represents a @file{.pom} file content, or parts of it."
(pom-ref content "parent"))
(define* (find-parent content inputs #:optional local-packages)
- "Find the parent pom for the pom file whith @var{content} in a package's
+ "Find the parent pom for the pom file with @var{content} in a package's
@var{inputs}. When the parent pom cannot be found in @var{inputs}, but
@var{local-packages} is defined, the parent pom is looked up in it.
@@ -246,14 +246,14 @@ to re-declare the namespaces in the top-level element."
"Open @var{pom-file}, and override its content, rewritting its dependencies
to set their version to the latest version available in the @var{inputs}.
-@var{#:with-plugins?} controls whether plugins are also overiden.
+@var{#:with-plugins?} controls whether plugins are also overridden.
@var{#:with-build-dependencies?} controls whether build dependencies (whose
-scope is not empty) are also overiden. By default build dependencies and
-plugins are not overiden.
+scope is not empty) are also overridden. By default build dependencies and
+plugins are not overridden.
@var{#:excludes} is an association list of groupID to a list of artifactIDs.
When a pair (groupID, artifactID) is present in the list, its entry is
-removed instead of being overiden. If the entry is ignored because of the
+removed instead of being overridden. If the entry is ignored because of the
previous arguments, the entry is not removed.
@var{#:local-packages} is an association list that contains additional version
@@ -262,7 +262,7 @@ not found in @var{inputs}, information from this list is used instead to determi
the latest version of the package. This is an association list of group IDs
to another association list of artifact IDs to a version number.
-Returns nothing, but overides the @var{pom-file} as a side-effect."
+Returns nothing, but overrides the @var{pom-file} as a side-effect."
(define pom (get-pom pom-file))
(define (ls dir)